ScummVM logo Main website - Forums - BuildBot - Doxygen - Planet
Contact us - Buy Supported Games: GOG.com
Log in curved edge

Compiling ScummVM/Visual StudioCompiling ScummVM/Visual Studio

Contents

Compiling ScummVM with Visual Studio under Windows

Compiling ScummVM under Windows is not an awfully hard task, however there are some things that don't just work out of the box

Support for MS Visual Studio 2005 (MSVC8) was removed on 2014-06-21. Use a newer version of Visual Studio.

Things needed

Visual Studio 2013

There exist several versions of Visual Studio 2013. A feature comparison can be found here

You can obtain the free Express version of Visual C++ 2013 here

Although Visual Studio 2013 or 2012 is preferred, older versions of Visual Studio may work so long as you have them updated to their latest Service Pack revisions. In fact, we suggest making sure that you always have the latest Service Packs and patches applied for these tool sets. In some cases, fixes were put into the free-to-download "Processor Pack" add-on for Visual C++. So, download the latest Service Pack and the latest Processor Pack for whatever version of Visual C++ you are using to make sure you won't run into compiler bugs that prevent the compilation of ScummVM.

Additional tools

You will need to download and install nasm which is used for assembler versions of our scalers.

Precompiled libraries

To ease the whole process, a package of all the needed precompiled libraries has been created. All you need to do is:

  • Download the precompiled libraries.
  • Download the latest SDL runtime library - latest version is 1.2.15 at the time this was written, you can find the latest version here.
  • Download the FreeType library. You'll need the complete package and the developer libraries. You'll need to copy the .lib files to your Visual Studio vc/lib folder, and the freetype6.dll and zlib1.dll files from the Freetype bin folder (default c:\Program Files (x86)\GnuWin32\bin) to your Windows folder.
  • Download the libjpeg-turbo library and copy the library files to your Visual Studio VC/lib folder,
  • Unzip the precompiled libraries archive maintaining directory structure
  • Run install.bat (Visual Studio 2008 only) or add the libraries by hand (Visual Studio 2010)
  • You don't need to add the libraries to Visual Studio, as the installer automatically copies the necessary files in the appropriate directories of Visual Studio. Please note that this installer has only been tested with Visual Studio 2005 and 2008. If you get errors with earlier versions of Visual Studio, simply copy the directories bin, lib and include inside the directory where Visual C++ is installed. If you're not sure how to do that, check the section "Adding all libraries to Visual Studio 2008" further on
  • Unzip sdl.dll from the SDL runtime in the same directory where the scummvm executable will be created (under dists\<msvc_dir>\scummvm_Release) where <msvc_dir> is:
    • msvc9 for Visual Studio 2008
    • msvc10 for Visual Studio 2010
    • msvc11 for Visual Studio 2012
    • msvc12 for Visual Studio 2013
  • Skip to step "Ready to compile ScummVM"

Building the libraries yourself

Refer to the instructions for compiling the libraries yourself


Adding all libraries to Visual Studio 2010 and newer

The way libraries are added has been changed in Visual Studio 2010, compared to earlier versions. Copy all of the precompiled libraries in a separate folder (e.g. c:\scummvm_libs). Then, there are two different ways of adding this directory to Visual Studio:

  • Right click My Computer->Properties->Advanced (Win 2000/XP) or Advanced System Settings->Advanced (Vista/Win 7/Win 8)->Environment Variables->New (System Variable), with a variable name of "SCUMMVM_LIBS" and a value of the folder where you unpacked your precompiled libraries (e.g. "C:\scummvm_vs_libs"). You need to restart Visual Studio, if it's already running, for the change to take effect.
  • If the above method doesn't work, open the ScummVM solution in Visual Studio, and go to View->Property Manager or View->Other Views->Property Manager (depending on your layout configuration). From there, open the ScummVM project, and go to the configuration you want to build (e.g. Debug|Win32) and click on "Microsoft.Cpp.Win32.user". From there, go to "VC++ directories" and add the 3 library directories in the appropriate places, i.e.:
 Executable Directories: add "C:\scummvm_vs_libs\bin;" at the beginning
 Include Directories: add "C:\scummvm_vs_libs\include;" at the beginning
 Library Directories: add "C:\scummvm_vs_libs\lib\x86" (or x64, if you're building a 64-bit version) at the beginning

If if still fails to build, saying it can't find a lib file, go to the project properties of the ScummVM project, Configuration Properties->Linker->General->Additional Library Directories and add your lib folder in there


Adding all libraries to Visual Studio 2008

There are two ways of adding the libraries to Visual Studio. You can either copy all the header and library files inside the appropriate directories of Visual C++ or tell Visual C++ where to look for them.

First method: Copy the files inside VC++'s folders

The first method of adding the required libraries is to go to each individual compiled library and copy the header and library files.

You'll need the following:

Libraries

 libFLAC_static.lib - static build of libFLAC (from folder obj\release\lib where you unzipped libFLAC)
 libmad.lib - static build of libMAD (from folder msvc++\Release where you unzipped libmad)
 libmpeg2.lib - static build of libMPEG2 (from folder vc++\Release where you unzipped mpeg2dec)
 libpng.lib - static build of libpng (from folder projects\visualc71\Win32_LIB_Release where you unzipped libpng)
 ogg_static.lib - static build of libOGG (from folder win32\Static_Release where you unzipped libogg)
 sdl.lib - static build of SDL (from folder lib where you unzipped SDL)
 vorbisfile_static.lib - static build of vorbisfile (from folder win32\VorbisFile_Static_Release where you unzipped libvorbis)
 vorbis_static.lib - static build of libvorbis (from folder win32\Vorbis_Static_Release where you unzipped libvorbis)
 vorbisenc_static.lib - static build of libvorbis (from folder win32\Vorbisenc_Static_Release where you unzipped libvorbis)
 zlib.lib - static build of zlib (from folder projects\visualc6\Win32_LIB_Release where you unzipped zlib)

Copy those inside VC's lib folder (e.g. C:\Program Files\Microsoft Visual Studio 8\VC\lib)

Header files

 [TODO]

Copy those inside VC's include folder (e.g. C:\Program Files\Microsoft Visual Studio 8\VC\include)

Executable files

 nasmw.exe - from the NASM zip

Copy this as nasmw.exe AND as nasm.exe inside VC's bin folder (e.g. C:\Program Files\Microsoft Visual Studio 8\VC\bin)

Second method: Tell VC++ where to look

The second method is to tell VC++ where to look for the required libraries and header files

Go to Tools->Options->Projects and solutions->VC++ directories.

In the executable files section, make sure that the path to nasm is included and that nasmw.exe in that folder has been copied to nasm.exe. Failure to do that will give you an error in VS (a custom building step has returned an error)

In the include files section, make sure that the include folders for libogg, libvorbis, libmad, zlib, mpeg2dec and SDL are in the list. If you need FLAC, include the FLAC include folder in the list too

In the library files section, make sure that the static libraries for vorbis, vorbisfile, libogg, zlib, mpeg2dec, libmad and SDL are included. If you're building 0.8.0 final or earlier, include the release folder of zlibdll too (in the zlib source folder, contrib\vstudio\vc8\x86\zlibdllrelease). If you need FLAC, include the FLAC libraries folder too

Finally, if you need to compile ScummVM with FLAC support, go to Configuration Properties->C/C++->Preprocessor and add "USE_FLAC" in the Preprocessor Definitions field. Also, go to linker->input and add "libflac_static.lib" in the Additional Dependencies field.


Enabling the console

Since information on doing this is not that easy to find, here's how to enable the console in the resulting ScummVM executable. The default project subsystem is "Windows" instead of "Console", which means that the console will not be shown.

To show the console, right-click on the "scummvm" project and go to Properties. There, go to Configuration Properties->Linker->System and change the "Subsystem" property from "Windows (/SUBSYSTEM:WINDOWS)" to "Console (/SUBSYSTEM:CONSOLE)". Then, go to Linker->Advanced and set the entry point to be "WinMainCRTStartup" (special thanks to Jubanka/knakos for his tip on entrypoint).

Creating the project files

First, open relevant solution file in devtools/create_project/msvc<your-version>, and build create_project.exe file.

Then put the resulting create_project.exe file in dists/msvc<your-version> and run create_msvc<your-version>.bat in that directory.

The program will generate whole solution projects for building ScummVM.

Ready to compile ScummVM

If you got all the libraries compiled, you're ready to compile the latest version of ScummVM!

Open the solution file in dists\msvcXX, select the "Release" configuration from the configuration manager pulldown menu and then go to Build->Build solution, or just press Control-F7 to compile it.

The ScummVM executable should be in the folder dists\msvcXX\scummvm_Release as "scummvm.exe".

You'll need to copy sdl.dll from the SDL runtime archive (or the latest devel archive) in the directory where scummvm.exe is

 

curved edge   curved edge