Difference between revisions of "Compiling ScummVM/Visual Studio"

From ScummVM :: Wiki
Jump to navigation Jump to search
(→‎libvorbis: update)
 
(34 intermediate revisions by 8 users not shown)
Line 1: Line 1:
== Compiling ScummVM with Visual Studio 2003/2005 under Windows ==
+
== Compiling ScummVM with Visual Studio under Windows ==
 
 
 
 
Compiling ScummVM under Windows is not an awfully hard task, however there are some things that don't just work out of the box
 
  
 +
Compiling ScummVM with Visual Studio is not an awfully hard task. It is however slightly more complicated than using MinGW. We guide you through the steps to make ScummVM compile with Visual Studio on this page.
  
 
== Things needed ==
 
== Things needed ==
 +
Visual Studio 2008-2019
  
=== Visual Studio 2008 ===
+
=== Visual Studio ===
There exist several versions of Visual Studio 2008. A feature comparison can be found
+
There exists a free Community version of Visual Studio [https://visualstudio.microsoft.com/ here] that can be used.
[http://msdn.microsoft.com/vstudio/products/compare/default.aspx here]
+
Professional Visual Studioversions are working fine too.
 
 
You can obtain the free Express version of VS2008 [http://msdn.microsoft.com/vstudio/express/default.aspx here]
 
 
 
Although Visual Studio 2008 is preferred if you happen to use the older Visual Studio 2005
 
you have to have at least Service Pack 1 installed for it (as Visual Studio 2005
 
without Service Pack 1 has problems with ScummVM's template code).
 
 
 
=== Precompiled libraries ===
 
To ease the whole process, a package of all the needed precompiled libraries has been created.
 
All you need to do is:
 
* Download the precompiled libraries and the [http://www.libsdl.org/release/SDL-1.2.12-win32.zip latest SDL runtime library] - latest version is 1.2.12 at the time this was written, you can find the latest version [http://www.libsdl.org/download-1.2.php here]. Mirrors for precompiled libraries:
 
** [http://robertmegone.com/scummvm/build/scummvm_vs_libs.zip Mirror 1]
 
** [http://rapidshare.com/files/234099155/scummvm_vs_libs.zip Mirror 2] (RapidShare)
 
* Unzip the precompiled libraries archive maintaining directory structure
 
* Run install.bat (Visual Studio 2005/2008 only)
 
* You don't need to add the libraries to Visual Studio, as the installer automatically copies the necessary files in the appropriate directories of Visual Studio. Please note that this installer has only been tested with Visual Studio 2005 and 2008. If you get errors with earlier versions of Visual Studio, simply copy the directories ''bin'', ''lib'' and ''include'' inside the directory where Visual C++ is installed. If you're not sure how to do that, check the section "[[Compiling_ScummVM/Visual_Studio#Adding_all_libraries_to_Visual_Studio|Adding all libraries to Visual Studio]]" further on
 
* Unzip sdl.dll from the SDL runtime in the same directory where the scummvm executable will be created (default is under dits\msvc9\scummvm_Release, substitute msvc9 for msvc8 if you're using Visual Studio 2005 and msvc7 if you're using Visual Studio 2003)
 
* Skip to step "[[Compiling_ScummVM/Visual_Studio#Ready to compile ScummVM|Ready to compile ScummVM]]"
 
 
 
=== Libraries needed ===
 
 
 
* [http://www.libsdl.org/download-1.2.php SDL 1.2], file SDL-devel-1.2.XX-VC8.zip (where XX is the current release number)
 
Latest stable version at the time of writing this: [http://www.libsdl.org/release/SDL-devel-1.2.13-VC8.zip 1.2.13]
 
 
 
* [ftp://ftp.zytor.com/pub/nasm/releasebuilds/ NASM]
 
Latest stable version at the time of writing this: [ftp://ftp.zytor.com/pub/nasm/releasebuilds/2.06rc12/win32/nasm-2.06rc12-win32.zip 2.06rc12]
 
 
 
* [http://downloads.xiph.org/releases/ogg/ libogg] and [http://downloads.xiph.org/releases/vorbis/ libvorbis] for OGG support.
 
Note that the libraries included in the "vorbis" package won't work. You need libogg and libvorbis, not vorbis.
 
Latest stable versions at the time of writing this: [http://downloads.xiph.org/releases/ogg/libogg-1.1.4.zip 1.1.4] and [http://downloads.xiph.org/releases/vorbis/libvorbis-1.2.3.zip 1.2.3].
 
 
 
* [ftp://ftp.mars.org/pub/mpeg/ libmad] for MP3 support.
 
Latest stable version at the time of writing this: [ftp://ftp.mars.org/pub/mpeg/libmad-0.15.1b.tar.gz 0.15.1b]
 
 
 
* [http://sourceforge.net/project/showfiles.php?group_id=13478&package_id=12677 libFLAC] for FLAC support.
 
Latest stable version at the time of writing this: [http://sourceforge.net/project/showfiles.php?group_id=13478&package_id=12677&release_id=539981 1.2.1]
 
 
 
* [http://libmpeg2.sourceforge.net/downloads.html libmpeg2] for MPEG-2 support.
 
Get the latest mpeg2dec release from this page, libmpeg2 is included there.
 
Latest stable version at the time of writing this: [http://libmpeg2.sourceforge.net/files/libmpeg2-0.5.1.tar.gz 0.5.1]
 
 
 
* [http://www.zlib.net/ zlib]
 
You need the latest zlib source code. If you wish to compile ScummVM 0.8.0 or earlier with zlib support, you'll also need [http://www.winimage.com/zLibDll/crtdll.zip crtdll.lib].
 
Latest stable version at the time of writing this: [http://www.zlib.net/zlib123.zip 1.2.3]
 
 
 
* [ftp://ftp.simplesystems.org/pub/libpng/png/src/ libpng] (for ScummVM tools)
 
You need the latest libpng source code.
 
Latest stable version at the time of writing this: [ftp://ftp.simplesystems.org/pub/libpng/png/src/libpng-1.2.36.tar.gz 1.2.36]
 
 
 
== Building the libraries ==
 
 
 
Now, we need to compile the required libraries.
 
 
 
Note that you'll need to build all libraries with the same configuration settings (debug or release). If you don't need a specific library, you can remove it from your build by going to Project->Properties, Configuration Properties->C/C++->Preprocessor and remove the "USE_XXX" directive for that library from there. For example, to remove OGG support, remove the USE_VORBIS directive.
 
 
 
Also, make sure to disable the inclusion of default libraries in all libraries. You can do this from the project properties->Librarian->General and setting "Ignore all default libraries" to "Yes (/NODEFAULTLIB)" (special thanks to nolange for this tip). Finally, make sure that optimization is set to "Maximize speed" (or anything other than "Full optimization"), otherwise it will be impossible to build incremental debug builds later on (you'll get a warning saying "ignoring '/INCREMENTAL' due to '/LTCG' specification"). You can do this from the project properties->C/C++->Optimization, and set "Optimization" to "Maximize Speed (/O2)"
 
 
 
 
 
=== A note about VS2008/2005 ===
 
 
 
If you're building the libraries with VS2008/2005, you will get a lot of deprecation warnings. These are normal and nothing to worry about, they're just Microsoft's way of saying "This is a bad code practice. Use this instead". It's not easy to turn these off without several modifications to the code, so just ignore them.
 
 
 
Read more here:
 
 
 
http://msdn.microsoft.com/msdnmag/issues/05/05/SafeCandC/
 
 
 
http://www.gamedev.net/community/forums/topic.asp?topic_id=361433
 
 
 
http://blogs.msdn.com/oldnewthing/archive/2005/01/07/348437.aspx
 
 
 
If you do wish to make them disappear, you need to include on top the main function of each library, before the includes, the following lines:
 
 
 
  #if (_MSC_VER >= 1400) /* VC8+ (VS2005) */
 
  #pragma warning(disable : 4996) /* Disable all deprecation warnings */
 
  #endif /* VC8+ (VS2005) */
 
 
 
 
 
=== NASM ===
 
 
 
First of all, we need nasm. So unzip the nasm archive in a directory, copy
 
"nasmw.exe" to "nasm.exe" (because some projects call one and others call the other) and include it in the executable path of VS. To do this, go to Tools->Options->Projects and solutions->VC++ directories. Select "Executable files" from the top right and include the directory where you unzipped nasm into.
 
 
 
 
 
=== SDL ===
 
 
 
SDL is already compiled and needs no further changes, so we can skip the compilation step for it
 
 
 
 
 
=== zlib ===
 
 
 
You'll need the zlib source package. After unzipping it, go into the projects directory in the zlib source and open the solution under projects\visualc6. Right click on the "zlib" project, and go to its properties. Then, go to Configuration Properties->C/C++->Code Generation and change the Runtime library from "Multi-Threaded DLL (/MD)" to "Multi-Threaded (/MT)" (if you don't do this step, you'll have issues compiling ScummVM later on). Then, compile the "zlib" project using the LIB release configuration.
 
 
 
 
 
=== libogg ===
 
 
 
Compile this first, as many other libraries need it. Go to the win32 directory and build the "libogg_static" solution of your MSVC version (which should be found in one of the sub-directories).
 
 
 
=== libvorbis ===
 
 
 
You will need to use the "vorbis_static" solution. It should feature working x86 (Win32) and x64 (x64) targets by default.
 
 
 
'''Note''': When you do not include your ogg headers/libraries in your global MSVC path settings you will need to do the following: include the libogg include and library paths in VS. To do this, go to Tools->Options->Projects and solutions->VC++ directories and include the include directory of libogg as well as the directory with the compiled ogg library. You'll need vorbis, vorbisfile and also vorbisenc for ScummVM tools.
 
 
 
=== libmpeg2 ===
 
 
 
The VC6 solution files (inside the vc++ folder) need to be used for this library, but first they all need to be changed to DOS format, otherwise Visual Studio will complain that the project files are corrupted. Then, open file config.h inside the vc++ folder and comment out the following line, near the end of the file:
 
#define restrict __restrict
 
Open the solution and compile project "libmpeg2". After you compile it, go to its include directory, create a folder "mpeg2dec" in there and copy all files from the include folder in this subfolder. You will end up with 2 directories, "include" and "include\mpeg2dec" with the same files. This is needed, as ScummVM includes files from the "mpeg2dec" directory
 
 
 
 
 
=== libmad ===
 
 
 
Open and compile the "libmad" solution
 
 
 
'''Note for x64:''' When you want to build a x64 library for libmad you will need to create your own x64 config for it. You can do so by easy conversion of the existing libmad solution files for x86. Afterward you will need to edit the preprocessor definitons via: Properties -> Configuration Properties -> C/C++ -> Preprocessor -> Preprocessor Definitions: there you will need to replace "FPM_INTEL" with "FPM_64BIT" there.
 
 
 
You will also need to apply the following patch to mad.h: TODO (host it somewhere...)
 
 
 
=== FLAC ===
 
 
 
Open its solution and compile the libFLAC_static project. By default, optimization for this library is set to "full" in release builds, which will prevent you from performing incremental debug builds later on, so make sure to set it to "Maximize speed" (or anything other than "Full optimization"), otherwise it will be impossible to build incremental debug builds later on. Check the introductory section for more information. Also, FLAC OGGs are not needed, so support for these can be dropped by going to the libFLAC_static project settings and removing the FLAC__HAS_OGG switch from C/C++->Preprocessor->Preprocessor Definitions.
 
 
 
 
 
=== libpng ===
 
 
 
Open the solution under projects\visualc71. You also need zlib to compile this library, which must be placed in a folder named "zlib" outside libpng's directory. You need to change the settings of zlib like you have done before (i.e. from "Multi-Threaded DLL (/MD)" to "Multi-Threaded (/MT)"). Check the zlib section for more information.
 
 
 
 
 
== Adding all libraries to Visual Studio ==
 
 
 
There are two ways of adding the libraries to Visual Studio. You can either copy all the header and library files inside the appropriate directories of Visual C++ or tell Visual C++ where to look for them.
 
<br><br>
 
 
 
=== First method: Copy the files inside VC++'s folders ===
 
The '''first method''' of adding the required libraries is to go to each individual compiled library and copy the header and library files.
 
 
 
You'll need the following:<br><br>
 
'''Libraries'''<br>
 
  '''libFLAC_static.lib''' - static build of libFLAC (from folder obj\release\lib where you unzipped libFLAC)
 
  '''libmad.lib''' - static build of libMAD (from folder msvc++\Release where you unzipped libmad)
 
  '''libmpeg2.lib''' - static build of libMPEG2 (from folder vc++\Release where you unzipped mpeg2dec)
 
  '''libpng.lib''' - static build of libpng (from folder projects\visualc71\Win32_LIB_Release where you unzipped libpng)
 
  '''ogg_static.lib''' - static build of libOGG (from folder win32\Static_Release where you unzipped libogg)
 
  '''sdl.lib''' - static build of SDL (from folder lib where you unzipped SDL)
 
  '''vorbisfile_static.lib''' - static build of vorbisfile (from folder win32\VorbisFile_Static_Release where you unzipped libvorbis)
 
  '''vorbis_static.lib''' - static build of libvorbis (from folder win32\Vorbis_Static_Release where you unzipped libvorbis)
 
  '''vorbisenc_static.lib''' - static build of libvorbis (from folder win32\Vorbisenc_Static_Release where you unzipped libvorbis)
 
  '''zlib.lib''' - static build of zlib (from folder projects\visualc6\Win32_LIB_Release where you unzipped zlib)
 
 
 
Copy those inside VC's lib folder (e.g. C:\Program Files\Microsoft Visual Studio 8\VC\lib)
 
<br><br>
 
'''Header files'''<br>
 
  [TODO]
 
 
 
Copy those inside VC's include folder (e.g. C:\Program Files\Microsoft Visual Studio 8\VC\include)
 
<br><br>
 
'''Executable files'''<br>
 
  '''nasmw.exe''' - from the NASM zip
 
  
Copy this as nasmw.exe AND as nasm.exe inside VC's bin folder (e.g. C:\Program Files\Microsoft Visual Studio 8\VC\bin)
+
We do support older versions of Visual Studio too. However, on this page we focus on building ScummVM with Visual Studio. Building ScummVM with older Visual Studio 2008 can require additional work not described on this page.
<br><br>
 
  
=== Second method: Tell VC++ where to look ===
+
=== Needed Libraries ===
The '''second method''' is to tell VC++ where to look for the required libraries and header files
+
ScummVM relies on third-party libraries to implement certain functionality. Some of these libraries are required, like for example SDL, others are optional, like for example libtheora. We supply a set of prebuilt libraries for Visual Studio 2015. These have been build on Windows 8.1 using the Visual Studio 2015 Community Edition. The libraries can be found [http://www.scummvm.org/frs/build/scummvm_libs_2015.zip here].
  
Go to Tools->Options->Projects and solutions->VC++ directories.  
+
=== Installing Libraries ===
 +
The easiest way to make Visual Studio find the supplied libraries is by using the environment variable "SCUMMVM_LIBS". We describe this method now.
 +
To make it work you have to follow these steps:
 +
* Unzip the library zip to a directory of your choice. For example, you can unzip them into "C:\Users\YourUsername\Documents\scummvm_libs_2015".
 +
* Go to Control Panel -> Environment Variables and set up a new variable "SCUMMVM_LIBS" with a value of the path you extracted the zip in. It is important that you do point the variable to the folder containing the "bin", "include", and "lib" directories.
  
In the executable files section, make sure that the path to nasm is included and that nasmw.exe in that folder has been copied to nasm.exe. Failure to do that will give you an error in VS (a custom building step has returned an error)
+
=== Manually Building Libraries ===
 +
If you want to build libraries for use with Visual Studio yourself, please refer to the [[Compiling_ScummVM/Visual_Studio/Compiling_Libraries|instructions for compiling the libraries yourself]].
  
In the include files section, make sure that the include folders for libogg, libvorbis, libmad, zlib, mpeg2dec and SDL are in the list. If you need FLAC, include the FLAC include folder in the list too
+
== Preparing the Project Files ==
  
In the library files section, make sure that the static libraries for vorbis, vorbisfile, libogg, zlib, mpeg2dec, libmad and SDL are included. If you're building 0.8.0 final or earlier, include the release folder of zlibdll too (in the zlib source folder, contrib\vstudio\vc8\x86\zlibdllrelease). If you need FLAC, include the FLAC libraries folder too
+
=== Building create_project ===
  
Finally, if you need to compile ScummVM with FLAC support, go to Configuration Properties->C/C++->Preprocessor and add "USE_FLAC" in the Preprocessor Definitions field. Also, go to linker->input and add "libflac_static.lib" in the Additional Dependencies field.
+
ScummVM uses a configure/Make based build system. We have a tool to generate Visual Studio project files from this build system. The first steep you need to take is building this tool called "create_project".
  
 +
First, open the solution file "devtools\create_project\msvc\create_project.sln". Then simply build the solution. The project file should automatically assure that the resulting "create_project.exe" is copied to "dists\msvc". If not, you will have to copy it yourself.
  
== Enabling the console ==
+
=== Generating the Project Files ===
  
Since information on doing this is not that easy to find, here's how to enable the console in the resulting ScummVM executable.
+
Simply run the batch script "dists/msvc/create_msvc.bat". It will guide you through configuring ScummVM.
The default project subsystem is "Windows" instead of "Console", which means that the console will not be shown.  
 
  
To show the console, right-click on the "scummvm" project and go to Properties. There, go to Configuration Properties->Linker->System and change the "Subsystem" property from "Windows (/SUBSYSTEM:WINDOWS)" to "'''Console (/SUBSYSTEM:CONSOLE)'''". Then, go to Linker->Advanced and set the entry point to be "'''WinMainCRTStartup'''" (special thanks to [[User:Jubanka|Jubanka/knakos]] for his tip on entrypoint).
+
'''IMPORTANT''': You will have to re-generate the project files whenever new source files have been added to or removed from the configure/Make based build system. When you add new files to ScummVM, you will ''have'' to add them to the respective "module.mk" file to assure ScummVM still builds fine with the configure/Make based build system.
  
 +
== Compiling ScummVM ==
  
== Ready to compile ScummVM ==
+
If you followed all the steps, you are now ready to compile ScummVM with Visual Studio. Congratulations!
  
If you got all the libraries compiled, you're ready to compile the latest version of ScummVM!
+
Simply open the generated solution file in "dists\msvc\scummvm.sln". Now you can ask it to build the desired configuration. By default it will build a debug configuration which is ideal to hack on ScummVM.
  
Open the solution file in dists\msvc9 (msvc8 for VS2005 and msvc7 for VS2003), select the "Release" configuration from the configuration manager pulldown menu and then go to Build->Build solution, or just press Control-F7 to compile it.
+
'''IMPORTANT''': You'll need to copy the matching SDL.dll file to a location Windows picks up to run the resulting binary. The easiest way to do this is to place the SDL.dll file in the directory where scummvm.exe is. There are multiple SDL.dll files to choose from, depending on your build configuration. Simply pick the right one from the prebuilt libraries. For example, if you build a Win32 Debug configuration, you will need to use "libs/x86/Debug/SDL.dll".
  
The ScummVM executable should be in the folder dists\msvc9\scummvm_Release as "scummvm.exe".
+
== Compiling without Console/Status Window ==
  
You'll need to copy sdl.dll from the SDL runtime archive (or the latest devel archive) in the directory where scummvm.exe is
+
If you want to run ScummVM without the console Window being present by default, there are two things you need to do:
 +
* In the Project Options for the scummvm project, go to the Linker | System | SubSystem line, and change the /SUBSYSTEM:CONSOLE to /SUBSYSTEM:WINDOWS
 +
* In the file backends/platform/sdl/win32/win32.cpp, change the parameter from true to false in the first line of OSystem_Win32::initBackend:
 +
ConfMan.registerDefault("console", false);

Latest revision as of 13:51, 20 April 2019

Compiling ScummVM with Visual Studio under Windows

Compiling ScummVM with Visual Studio is not an awfully hard task. It is however slightly more complicated than using MinGW. We guide you through the steps to make ScummVM compile with Visual Studio on this page.

Things needed

Visual Studio 2008-2019

Visual Studio

There exists a free Community version of Visual Studio here that can be used. Professional Visual Studioversions are working fine too.

We do support older versions of Visual Studio too. However, on this page we focus on building ScummVM with Visual Studio. Building ScummVM with older Visual Studio 2008 can require additional work not described on this page.

Needed Libraries

ScummVM relies on third-party libraries to implement certain functionality. Some of these libraries are required, like for example SDL, others are optional, like for example libtheora. We supply a set of prebuilt libraries for Visual Studio 2015. These have been build on Windows 8.1 using the Visual Studio 2015 Community Edition. The libraries can be found here.

Installing Libraries

The easiest way to make Visual Studio find the supplied libraries is by using the environment variable "SCUMMVM_LIBS". We describe this method now. To make it work you have to follow these steps:

  • Unzip the library zip to a directory of your choice. For example, you can unzip them into "C:\Users\YourUsername\Documents\scummvm_libs_2015".
  • Go to Control Panel -> Environment Variables and set up a new variable "SCUMMVM_LIBS" with a value of the path you extracted the zip in. It is important that you do point the variable to the folder containing the "bin", "include", and "lib" directories.

Manually Building Libraries

If you want to build libraries for use with Visual Studio yourself, please refer to the instructions for compiling the libraries yourself.

Preparing the Project Files

Building create_project

ScummVM uses a configure/Make based build system. We have a tool to generate Visual Studio project files from this build system. The first steep you need to take is building this tool called "create_project".

First, open the solution file "devtools\create_project\msvc\create_project.sln". Then simply build the solution. The project file should automatically assure that the resulting "create_project.exe" is copied to "dists\msvc". If not, you will have to copy it yourself.

Generating the Project Files

Simply run the batch script "dists/msvc/create_msvc.bat". It will guide you through configuring ScummVM.

IMPORTANT: You will have to re-generate the project files whenever new source files have been added to or removed from the configure/Make based build system. When you add new files to ScummVM, you will have to add them to the respective "module.mk" file to assure ScummVM still builds fine with the configure/Make based build system.

Compiling ScummVM

If you followed all the steps, you are now ready to compile ScummVM with Visual Studio. Congratulations!

Simply open the generated solution file in "dists\msvc\scummvm.sln". Now you can ask it to build the desired configuration. By default it will build a debug configuration which is ideal to hack on ScummVM.

IMPORTANT: You'll need to copy the matching SDL.dll file to a location Windows picks up to run the resulting binary. The easiest way to do this is to place the SDL.dll file in the directory where scummvm.exe is. There are multiple SDL.dll files to choose from, depending on your build configuration. Simply pick the right one from the prebuilt libraries. For example, if you build a Win32 Debug configuration, you will need to use "libs/x86/Debug/SDL.dll".

Compiling without Console/Status Window

If you want to run ScummVM without the console Window being present by default, there are two things you need to do:

  • In the Project Options for the scummvm project, go to the Linker | System | SubSystem line, and change the /SUBSYSTEM:CONSOLE to /SUBSYSTEM:WINDOWS
  • In the file backends/platform/sdl/win32/win32.cpp, change the parameter from true to false in the first line of OSystem_Win32::initBackend:
ConfMan.registerDefault("console", false);