Difference between revisions of "Compiling ScummVM/Visual Studio"

From ScummVM :: Wiki
Jump to navigation Jump to search
(Simplify instructions)
 
(30 intermediate revisions by 10 users not shown)
Line 1: Line 1:
== Compiling ScummVM with Visual Studio 2008/2010 under Windows ==
== Installing the needed software and libraries ==


In this page, we guide you through the steps to compile ScummVM with Visual Studio.


Compiling ScummVM under Windows is not an awfully hard task, however there are some things that don't just work out of the box
=== Visual Studio ===
You can get the free Community version of Visual Studio [https://visualstudio.microsoft.com/vs/ here].
Professional Visual Studio versions are working fine too.


== Things needed ==
When installing Visual Studio 2017 or later, make sure to select the "Desktop Development with C++" workload.


=== Visual Studio 2010 or 2008 ===
Building ScummVM with Visual Studio versions older than 2008 will require additional work which is not described here.
There exist several versions of Visual Studio 2010. A feature comparison can be found
[http://msdn.microsoft.com/vstudio/products/compare/default.aspx here]


You can obtain the free Express version of Visual C++ 2010 [http://msdn.microsoft.com/vstudio/express/default.aspx here]
=== Needed Libraries ===
ScummVM relies on third-party libraries for common features, such as MP3 decoding. Some of these libraries, like SDL, are required, whereas others like libtheora are optional.


Although Visual Studio 2010 or 2008 is preferred, older versions of Visual Studio may work so long as you have them updated to their latest Service Pack revisions. In fact, we suggest making sure that you always have the latest Service Packs and patches applied for these tool sets. In some cases, fixes were put into the free-to-download "Processor Pack" add-on for Visual C++. So, download the latest Service Pack and the latest Processor Pack for whatever version of Visual C++ you are using to make sure you won't run into compiler bugs that prevent the compilation of scummvm.
We supply a set of prebuilt libraries for Visual Studio 2015 and later, which can be found [http://downloads.scummvm.org/frs/build/scummvm_libs_2015.zip here].


=== Precompiled libraries ===
These libraries have been built on Windows 8.1 using the Visual Studio 2015 Community Edition.
To ease the whole process, a package of all the needed precompiled libraries has been created.  
All you need to do is:
* Download the precompiled libraries and the [http://www.libsdl.org/release/SDL-1.2.12-win32.zip latest SDL runtime library] - latest version is 1.2.12 at the time this was written, you can find the latest version [http://www.libsdl.org/download-1.2.php here]. Mirrors for precompiled libraries:
** [http://robertmegone.com/scummvm/build/scummvm_vs_libs.zip Mirror 1]
** [http://rapidshare.com/files/411489377/scummvm_vs_libs.zip Mirror 2] (RapidShare)
* Unzip the precompiled libraries archive maintaining directory structure
* Run install.bat (Visual Studio 2005/2008 only)
* You don't need to add the libraries to Visual Studio, as the installer automatically copies the necessary files in the appropriate directories of Visual Studio. Please note that this installer has only been tested with Visual Studio 2005 and 2008. If you get errors with earlier versions of Visual Studio, simply copy the directories ''bin'', ''lib'' and ''include'' inside the directory where Visual C++ is installed. If you're not sure how to do that, check the section "[[Compiling_ScummVM/Visual_Studio#Adding_all_libraries_to_Visual_Studio|Adding all libraries to Visual Studio]]" further on
* Unzip sdl.dll from the SDL runtime in the same directory where the scummvm executable will be created (default is under dits\msvc9\scummvm_Release, substitute msvc9 for msvc8 if you're using Visual Studio 2005 and msvc7 if you're using Visual Studio 2003)
* Skip to step "[[Compiling_ScummVM/Visual_Studio#Ready to compile ScummVM|Ready to compile ScummVM]]"


=== Building the libraries yourself ===
If you want to build libraries for use with Visual Studio yourself, please refer to the [[Compiling_ScummVM/Visual_Studio/Compiling_Libraries|instructions for compiling the libraries yourself]].
Refer to the [[Compiling_ScummVM/Visual_Studio/Compiling_Libraries|instructions for compiling the libraries yourself]]


=== Installing Libraries ===
The easiest way to make Visual Studio find the supplied libraries is by using the environment variable "SCUMMVM_LIBS". You can set it by performing the following steps:
* Unzip the library zip to a directory of your choice, for example "C:\Users\YourUsername\Documents\scummvm_libs_2015".
* Go to Start Menu > Control Panel > System > Advanced Settings > Environment Variables and add a new variable "SCUMMVM_LIBS" with a value of the path you extracted the zip in. It is important that you do point the variable to the folder containing the "bin", "include", and "lib" directories.


== Adding all libraries to Visual Studio 2010==
== Preparing the Project Files ==


The way libraries are added has been changed in Visual Studio 2010, compared to earlier versions. Copy all of the precompiled libraries in a separate folder (e.g. c:\scummvm_libs). Then, there are two different ways of adding this directory to Visual Studio:
=== Building create_project ===
* Right click My Computer->Properties->Advanced (Win 2000/XP) or Advanced System Settings->Advanced (Vista/Win 7)->Environment Variables->New (System Variable), with a variable name of "SCUMMVM_LIBS" and a value of the folder where you unpacked your precompiled libraries (e.g. "C:\scummvm_vs_libs")
* If the above method doesn't work, open the ScummVM solution in Visual Studio, and go to View->Property Manager or View->Other Views->Property Manager (depending on your layout configuration). From there, open the scummvm project, and go to the configuration you want to build (e.g. Debug|Win32) and click on "Microsoft.Cpp.Win32.user". From there, go to "VC++ directories" and add the 3 library directories in the appropriate places, i.e.:


  Executable Directories: add "C:\scummvm_vs_libs\bin;" at the beginning
ScummVM uses a configure/Make based build system. We have a tool to generate Visual Studio project files from this build system. The first step you need to take is building this tool called "create_project".
  Include Directories: add "C:\scummvm_vs_libs\include;" at the beginning
  Library Directories: add "C:\scummvm_vs_libs\lib\x86" (or x64, if you're building a 64-bit version) at the beginning


If if still fails to build, saying it can't find a lib file, go to the project properties of the scummvm project, Configuration Properties->Linker->General->Additional Library Directories and add your lib folder in there
First, open the solution file "devtools\create_project\msvc\create_project.sln". Then simply build the solution. The project file should automatically assure that the resulting "create_project.exe" is copied to "dists\msvc".


=== Generating the Project Files ===


== Adding all libraries to Visual Studio 2005/2008 ==
Simply run the batch script "dists/msvc/create_msvc.bat". It will guide you through configuring ScummVM.


There are two ways of adding the libraries to Visual Studio. You can either copy all the header and library files inside the appropriate directories of Visual C++ or tell Visual C++ where to look for them.
'''IMPORTANT''': You will have to re-generate the project files whenever new source files have been added to or removed from the configure/Make based build system. When you add new files to ScummVM, you will ''have'' to add them to the respective "module.mk" file to assure ScummVM still builds fine with the configure/Make based build system.
<br><br>


=== First method: Copy the files inside VC++'s folders ===
== Compiling ScummVM ==
The '''first method''' of adding the required libraries is to go to each individual compiled library and copy the header and library files.


You'll need the following:<br><br>
If you followed all the steps, you are now ready to compile ScummVM with Visual Studio. Congratulations!
'''Libraries'''<br>
  '''libFLAC_static.lib''' - static build of libFLAC (from folder obj\release\lib where you unzipped libFLAC)
  '''libmad.lib''' - static build of libMAD (from folder msvc++\Release where you unzipped libmad)
  '''libmpeg2.lib''' - static build of libMPEG2 (from folder vc++\Release where you unzipped mpeg2dec)
  '''libpng.lib''' - static build of libpng (from folder projects\visualc71\Win32_LIB_Release where you unzipped libpng)
  '''ogg_static.lib''' - static build of libOGG (from folder win32\Static_Release where you unzipped libogg)
  '''sdl.lib''' - static build of SDL (from folder lib where you unzipped SDL)
  '''vorbisfile_static.lib''' - static build of vorbisfile (from folder win32\VorbisFile_Static_Release where you unzipped libvorbis)
  '''vorbis_static.lib''' - static build of libvorbis (from folder win32\Vorbis_Static_Release where you unzipped libvorbis)
  '''vorbisenc_static.lib''' - static build of libvorbis (from folder win32\Vorbisenc_Static_Release where you unzipped libvorbis)
  '''zlib.lib''' - static build of zlib (from folder projects\visualc6\Win32_LIB_Release where you unzipped zlib)


Copy those inside VC's lib folder (e.g. C:\Program Files\Microsoft Visual Studio 8\VC\lib)
Simply open the generated solution file in "dists\msvc\scummvm.sln". Now you can ask it to build the desired configuration. By default it will build a debug configuration which is ideal to hack on ScummVM.
<br><br>
'''Header files'''<br>
  [TODO]


Copy those inside VC's include folder (e.g. C:\Program Files\Microsoft Visual Studio 8\VC\include)
'''IMPORTANT''': If you get errors about missing DLLs, you'll need to copy them to a location Windows picks up to run the resulting binary. The easiest way to do this is to place the DLL files in the directory where scummvm.exe is. There are multiple folders to choose from, depending on your build configuration. For example, if you build a Win32 Debug configuration, you will need to copy them from "SCUMMVM_LIBS\lib\x86\Debug" to "dists\msvc\Debugx86".
<br><br>
'''Executable files'''<br>
  '''nasmw.exe''' - from the NASM zip


Copy this as nasmw.exe AND as nasm.exe inside VC's bin folder (e.g. C:\Program Files\Microsoft Visual Studio 8\VC\bin)
NOTE: Several people have had errors about structure packing under Visual Studio 2019. In such cases, you need to update [http://libsdl.org/download-2.0.php SDL2] with the latest version.
<br><br>


=== Second method: Tell VC++ where to look ===
== Compiling with Console/Text Output ==
The '''second method''' is to tell VC++ where to look for the required libraries and header files


Go to Tools->Options->Projects and solutions->VC++ directories.
By default ScummVM is compiled as a Windows subsystem application with no console output. If you need the console, you can do one of the following:
 
* In the create_project command, add <code>--enable-text-console</code>.
In the executable files section, make sure that the path to nasm is included and that nasmw.exe in that folder has been copied to nasm.exe. Failure to do that will give you an error in VS (a custom building step has returned an error)
* In the Project Options for the scummvm project, go to the Linker | System | SubSystem line, and change the /SUBSYSTEM:WINDOWS to /SUBSYSTEM:CONSOLE
 
In the include files section, make sure that the include folders for libogg, libvorbis, libmad, zlib, mpeg2dec and SDL are in the list. If you need FLAC, include the FLAC include folder in the list too
 
In the library files section, make sure that the static libraries for vorbis, vorbisfile, libogg, zlib, mpeg2dec, libmad and SDL are included. If you're building 0.8.0 final or earlier, include the release folder of zlibdll too (in the zlib source folder, contrib\vstudio\vc8\x86\zlibdllrelease). If you need FLAC, include the FLAC libraries folder too
 
Finally, if you need to compile ScummVM with FLAC support, go to Configuration Properties->C/C++->Preprocessor and add "USE_FLAC" in the Preprocessor Definitions field. Also, go to linker->input and add "libflac_static.lib" in the Additional Dependencies field.
 
 
== Enabling the console ==
 
Since information on doing this is not that easy to find, here's how to enable the console in the resulting ScummVM executable.
The default project subsystem is "Windows" instead of "Console", which means that the console will not be shown.
 
To show the console, right-click on the "scummvm" project and go to Properties. There, go to Configuration Properties->Linker->System and change the "Subsystem" property from "Windows (/SUBSYSTEM:WINDOWS)" to "'''Console (/SUBSYSTEM:CONSOLE)'''". Then, go to Linker->Advanced and set the entry point to be "'''WinMainCRTStartup'''" (special thanks to [[User:Jubanka|Jubanka/knakos]] for his tip on entrypoint).
 
 
== Ready to compile ScummVM ==
 
If you got all the libraries compiled, you're ready to compile the latest version of ScummVM!
 
Open the solution file in dists\msvcXX (msvc10 for VS2010, msvc9 for VS2008 or msvc8 for VS2005), select the "Release" configuration from the configuration manager pulldown menu and then go to Build->Build solution, or just press Control-F7 to compile it.
 
The ScummVM executable should be in the folder dists\msvc9\scummvm_Release as "scummvm.exe".
 
You'll need to copy sdl.dll from the SDL runtime archive (or the latest devel archive) in the directory where scummvm.exe is

Latest revision as of 01:48, 29 March 2021

Installing the needed software and libraries

In this page, we guide you through the steps to compile ScummVM with Visual Studio.

Visual Studio

You can get the free Community version of Visual Studio here. Professional Visual Studio versions are working fine too.

When installing Visual Studio 2017 or later, make sure to select the "Desktop Development with C++" workload.

Building ScummVM with Visual Studio versions older than 2008 will require additional work which is not described here.

Needed Libraries

ScummVM relies on third-party libraries for common features, such as MP3 decoding. Some of these libraries, like SDL, are required, whereas others like libtheora are optional.

We supply a set of prebuilt libraries for Visual Studio 2015 and later, which can be found here.

These libraries have been built on Windows 8.1 using the Visual Studio 2015 Community Edition.

If you want to build libraries for use with Visual Studio yourself, please refer to the instructions for compiling the libraries yourself.

Installing Libraries

The easiest way to make Visual Studio find the supplied libraries is by using the environment variable "SCUMMVM_LIBS". You can set it by performing the following steps:

  • Unzip the library zip to a directory of your choice, for example "C:\Users\YourUsername\Documents\scummvm_libs_2015".
  • Go to Start Menu > Control Panel > System > Advanced Settings > Environment Variables and add a new variable "SCUMMVM_LIBS" with a value of the path you extracted the zip in. It is important that you do point the variable to the folder containing the "bin", "include", and "lib" directories.

Preparing the Project Files

Building create_project

ScummVM uses a configure/Make based build system. We have a tool to generate Visual Studio project files from this build system. The first step you need to take is building this tool called "create_project".

First, open the solution file "devtools\create_project\msvc\create_project.sln". Then simply build the solution. The project file should automatically assure that the resulting "create_project.exe" is copied to "dists\msvc".

Generating the Project Files

Simply run the batch script "dists/msvc/create_msvc.bat". It will guide you through configuring ScummVM.

IMPORTANT: You will have to re-generate the project files whenever new source files have been added to or removed from the configure/Make based build system. When you add new files to ScummVM, you will have to add them to the respective "module.mk" file to assure ScummVM still builds fine with the configure/Make based build system.

Compiling ScummVM

If you followed all the steps, you are now ready to compile ScummVM with Visual Studio. Congratulations!

Simply open the generated solution file in "dists\msvc\scummvm.sln". Now you can ask it to build the desired configuration. By default it will build a debug configuration which is ideal to hack on ScummVM.

IMPORTANT: If you get errors about missing DLLs, you'll need to copy them to a location Windows picks up to run the resulting binary. The easiest way to do this is to place the DLL files in the directory where scummvm.exe is. There are multiple folders to choose from, depending on your build configuration. For example, if you build a Win32 Debug configuration, you will need to copy them from "SCUMMVM_LIBS\lib\x86\Debug" to "dists\msvc\Debugx86".

NOTE: Several people have had errors about structure packing under Visual Studio 2019. In such cases, you need to update SDL2 with the latest version.

Compiling with Console/Text Output

By default ScummVM is compiled as a Windows subsystem application with no console output. If you need the console, you can do one of the following:

  • In the create_project command, add --enable-text-console.
  • In the Project Options for the scummvm project, go to the Linker | System | SubSystem line, and change the /SUBSYSTEM:WINDOWS to /SUBSYSTEM:CONSOLE