Difference between revisions of "Compiling ScummVM/Visual Studio/Compiling Libraries"

From ScummVM :: Wiki
Jump to navigation Jump to search
(→‎Libraries needed: Fixed libmad library)
(→‎libmad: Inlined the libmad patch into a source code box, as the link to it is down)
Line 99: Line 99:
 
'''Note for x64:''' When you want to build a x64 library for libmad you will need to create your own x64 config for it. You can do so by easy conversion of the existing libmad solution files for x86. For Release mode you will also need to edit the preprocessor definitons via: Properties -> Configuration Properties -> C/C++ -> Preprocessor -> Preprocessor Definitions: there you will need to replace "FPM_INTEL" with "FPM_64BIT".
 
'''Note for x64:''' When you want to build a x64 library for libmad you will need to create your own x64 config for it. You can do so by easy conversion of the existing libmad solution files for x86. For Release mode you will also need to edit the preprocessor definitons via: Properties -> Configuration Properties -> C/C++ -> Preprocessor -> Preprocessor Definitions: there you will need to replace "FPM_INTEL" with "FPM_64BIT".
  
You will also need to apply the following patch to mad.h: [http://robertmegone.com/scummvm/build/mad.patch mad.patch]
+
You will also need to apply the following patch to mad.h:
 +
 
 +
<source lang="diff">
 +
--- mad.h Tue Nov 03 18:29:06 2009
 +
+++ mad.h Tue Nov 03 18:29:14 2009
 +
@@ -24,7 +24,11 @@
 +
extern "C" {
 +
# endif
 +
 +
+#ifdef _WIN64
 +
+# define FPM_64BIT
 +
+#else
 +
# define FPM_INTEL
 +
+#endif
 +
</source>
  
 
=== FLAC ===
 
=== FLAC ===

Revision as of 09:57, 18 November 2011

Instructions for compiling the needed libraries for Visual Studio yourself

Libraries needed

  • SDL 1.2, file SDL-devel-1.2.XX-VC8.zip (where XX is the current release number)

Latest stable version at the time of writing this: 1.2.14

Latest stable version at the time of writing this: 2.09.10

Note that the libraries included in the "vorbis" package won't work. You need libogg and libvorbis, not vorbis. Latest stable versions at the time of writing this: 1.3.0 and 1.3.2.

Latest stable version at the time of writing this: 0.15.1b

Latest stable version at the time of writing this: 1.2.1

  • libmpeg2 for MPEG-2 support - no longer needed.

Get the latest mpeg2dec release from this page, libmpeg2 is included there. Latest stable version at the time of writing this: 0.5.1

You need the latest zlib source code. If you wish to compile ScummVM 0.8.0 or earlier with zlib support, you'll also need crtdll.lib. Latest stable version at the time of writing this: 1.2.5

  • libpng (for ScummVM tools, in particular convert_dxa)

You need the latest libpng source code. Latest Windows stable version at the time of writing this: 1.5.5

Building the libraries

Now, we need to compile the required libraries.

Note that you'll need to build all libraries with the same configuration settings (debug or release). If you don't need a specific library, you can remove it from your build by going to Project->Properties, Configuration Properties->C/C++->Preprocessor and remove the "USE_XXX" directive for that library from there. For example, to remove OGG support, remove the USE_VORBIS directive.

Also, make sure to disable the inclusion of default libraries in all libraries. You can do this from the project properties->Librarian->General and setting "Ignore all default libraries" to "Yes (/NODEFAULTLIB)" (special thanks to nolange for this tip). Finally, make sure that optimization is set to "Maximize speed" (or anything other than "Full optimization"), otherwise it will be impossible to build incremental debug builds later on (you'll get a warning saying "ignoring '/INCREMENTAL' due to '/LTCG' specification"). You can do this from the project properties->C/C++->Optimization, and set "Optimization" to "Maximize Speed (/O2)"


A note about VS2008/2005

If you're building the libraries with VS2008/2005, you will get a lot of deprecation warnings. These are normal and nothing to worry about, they're just Microsoft's way of saying "This is a bad code practice. Use this instead". It's not easy to turn these off without several modifications to the code, so just ignore them.

Read more here:

http://msdn.microsoft.com/msdnmag/issues/05/05/SafeCandC/

http://www.gamedev.net/community/forums/topic.asp?topic_id=361433

http://blogs.msdn.com/oldnewthing/archive/2005/01/07/348437.aspx

If you do wish to make them disappear, you need to include on top the main function of each library, before the includes, the following lines:

 #if (_MSC_VER >= 1400) /* VC8+ (VS2005) */
 #pragma warning(disable : 4996) /* Disable all deprecation warnings */ 
 #endif /* VC8+ (VS2005) */


NASM

First of all, we need nasm. So unzip the nasm archive in a directory, copy "nasmw.exe" to "nasm.exe" (because some projects call one and others call the other) and include it in the executable path of VS. To do this, go to Tools->Options->Projects and solutions->VC++ directories. Select "Executable files" from the top right and include the directory where you unzipped nasm into.


SDL

SDL is already compiled and needs no further changes, so we can skip the compilation step for it.

Note for x64: You will need to compile SDL for x64 on your own (as of the time of this writing), to do so you will also need to install the DirectX SDK found here. You will also need to apply this patch from here (patch gladly taken from the SDL mailing list).

After adding a new x64 configuration option in the project files, you may also need to remove "/MACHINE:I386" as additional linker command in Project->Properties, Configuration Properties->Linker->Command Line.

zlib

You'll need the zlib source package. After unzipping it, go into the projects directory in the zlib source and open the solution under projects\vstudio. Right click on the "zlib" project, and go to its properties. Then, go to Configuration Properties->C/C++->Code Generation and change the Runtime library from "Multi-Threaded DLL (/MD)" to "Multi-Threaded (/MT)" (if you don't do this step, you'll have issues compiling ScummVM later on). Then, compile the "zlib" project using the LIB release configuration.

libogg

Compile this first, as many other libraries need it. Go to the win32 directory and build the "libogg_static" solution of your MSVC version (which should be found in one of the sub-directories). The solution should feature working x86 (Win32) and x64 (x64) targets by default, so you can compile either of those depending on whether you decide to build an x86 or x64 ScummVM.

libvorbis

You will need to use the "vorbis_static" solution. It should feature working x86 (Win32) and x64 (x64) targets by default.

Note: When you do not include your ogg headers/libraries in your global MSVC path settings you will need to do the following: include the libogg include and library paths in VS. To do this, go to Tools->Options->Projects and solutions->VC++ directories and include the include directory of libogg as well as the directory with the compiled ogg library. You'll need vorbis, vorbisfile and also vorbisenc for ScummVM tools.

libmpeg2

The VC6 solution files (inside the vc++ folder) need to be used for this library, but first they all need to be changed to DOS format, otherwise Visual Studio will complain that the project files are corrupted. Then, open file config.h inside the vc++ folder and comment out the following line, near the end of the file:

#define restrict __restrict

Open the solution and compile project "libmpeg2". After you compile it, go to its include directory, create a folder "mpeg2dec" in there and copy all files from the include folder in this subfolder. You will end up with 2 directories, "include" and "include\mpeg2dec" with the same files. This is needed, as ScummVM includes files from the "mpeg2dec" directory

libmad

Open and compile the "libmad" solution

Note for x64: When you want to build a x64 library for libmad you will need to create your own x64 config for it. You can do so by easy conversion of the existing libmad solution files for x86. For Release mode you will also need to edit the preprocessor definitons via: Properties -> Configuration Properties -> C/C++ -> Preprocessor -> Preprocessor Definitions: there you will need to replace "FPM_INTEL" with "FPM_64BIT".

You will also need to apply the following patch to mad.h:

--- mad.h	Tue Nov 03 18:29:06 2009
+++ mad.h	Tue Nov 03 18:29:14 2009
@@ -24,7 +24,11 @@
 extern "C" {
 # endif
 
+#ifdef _WIN64
+# define FPM_64BIT
+#else
 # define FPM_INTEL
+#endif

FLAC

Open its solution and compile the libFLAC_static project. By default, optimization for this library is set to "full" in release builds, which will prevent you from performing incremental debug builds later on, so make sure to set it to "Maximize speed" (or anything other than "Full optimization"), otherwise it will be impossible to build incremental debug builds later on. Check the introductory section for more information. Also, FLAC OGGs are not needed, so support for these can be dropped by going to the libFLAC_static project settings and removing the FLAC__HAS_OGG switch from C/C++->Preprocessor->Preprocessor Definitions.

Note for x64: After converting the Win32 target to x64 you will need to adapt some file settings. First of all you will need to disable all *.nasm files in the "libFLAC_static" project, this can be easily done by right clicking on them and selecting "Properties", now set "Excluded From Build" to "true". Next you will need to adapt the Preprocessor Definitions: First of all remove the following defintions: "FLAC__CPU_IA32", "FLAC__HAS_NASM" and "FLAC__USE_3DNOW", now also add "FLAC__NO_ASM". Last but not least you will need to apply the following patch file to "bitreader.c" of the "libFLAC_static" project: flac.patch

libpng

Open the solution under projects\vstudio. You also need zlib to compile this library, which must be placed in a folder named "zlib" outside libpng's directory. You need to change the settings of zlib like you have done before (i.e. from "Multi-Threaded DLL (/MD)" to "Multi-Threaded (/MT)"). Check the zlib section for more information.