Open main menu
3 bytes added ,  08:03, 25 September 2009
m
Line 55: Line 55:
** A method which return an object pointer and expects the calling code to delete the object after use, should be named makeFOO; so for example, FSNode::openForReading() would become FSNode::makeReadStream()
** A method which return an object pointer and expects the calling code to delete the object after use, should be named makeFOO; so for example, FSNode::openForReading() would become FSNode::makeReadStream()
** A method which is supposed to free/delete/dellocate something should have a consistent name. Maybe freeFOO? deallocFOO? destroyFOO?
** A method which is supposed to free/delete/dellocate something should have a consistent name. Maybe freeFOO? deallocFOO? destroyFOO?
* Remove the 'addDefaultDirectory' calls from runGame in base/main.cpp. Reason: Their presence causes an asymmetry between the "detect a game" and "run a game" use cases, as different files are "seen" in each case. This can lead to subtle bugs, and also causes ugly code duplication in the AdvancedDetector code right now (there to work around asymmetries like this one)
* Remove the 'SearchMan.addDirectory' calls from runGame in base/main.cpp. Reason: Their presence causes an asymmetry between the "detect a game" and "run a game" use cases, as different files are "seen" in each case. This can lead to subtle bugs, and also causes ugly code duplication in the AdvancedDetector code right now (there to work around asymmetries like this one)
* add plugin API to fetch a fresh desc string for a given target ?!?
* add plugin API to fetch a fresh desc string for a given target ?!?
* completely get rid of #pragma pack for increased portability (what I mean here is not to simply remove it, but rather to change code which relies on structs to be packed to not do so anymore)
* completely get rid of #pragma pack for increased portability (what I mean here is not to simply remove it, but rather to change code which relies on structs to be packed to not do so anymore)
1,079

edits