Open main menu
1,300 bytes added ,  14:00, 27 June 2011
→‎TODO: Add some of my local TODO / IDEA notes to my Wiki page, in case somebody is interested in any of them
(Update my personal page)
(→‎TODO: Add some of my local TODO / IDEA notes to my Wiki page, in case somebody is interested in any of them)
Line 15: Line 15:
* Check for the presence of all required data files in all games; or, as a somewhat less extensive measure, at least do this: For games which were shipped on multiple volumes (floppies, CDs), check for the presence of at least one file per volume.
* Check for the presence of all required data files in all games; or, as a somewhat less extensive measure, at least do this: For games which were shipped on multiple volumes (floppies, CDs), check for the presence of at least one file per volume.
* Check for the presence of our external support files like kyra.dat, sky.cpt, etc., and also verify that they are up-to-date. For details, see [https://sourceforge.net/tracker/index.php?func=detail&aid=1520433&group_id=37116&atid=418823 FR #1520433]
* Check for the presence of our external support files like kyra.dat, sky.cpt, etc., and also verify that they are up-to-date. For details, see [https://sourceforge.net/tracker/index.php?func=detail&aid=1520433&group_id=37116&atid=418823 FR #1520433]
* we really should handle more errors, and handle them better. In the launcher, in engines, in backends... just everywhere.
* make "mass add" the new default behavior for the "add" button in the launcher
* finalize dealing  with the windows console, in particular
** hide it by default
** add a hotkey to toggle its visibility
** implement OSystem::displayLogFile() for Windows
** ...
=== Build system ===
* add a --with-sdk or so switch to configure, which can be used instead of setting env vars like PSPSDK etc -> better support for automatic re-configure runs
=== Buildbot ===
* run unit tests on build bot (for this, simply add an extra "test" builder alongside the other builders, which uses the regular build chain, but runs "make test" instead of doing a regular compilation. It wouldn't produce a "package" as output.
* add scummvm-tools to buildbot, so that users can get nightly build of the tools (ideally with UI) for at least Windows, Linux, Mac.
* provide windows installers from buildbot for scummvm and the tools


=== OSystem ===
=== OSystem ===
Line 20: Line 35:


=== Misc ===
=== Misc ===
* get rid of printf in frontend code. This has been mostly achieved now, but some uses remain, mostly related to detecting / adding games. there was an extensive discussion on -devel on how to resolve this, now only somebody needs to work on advancing this.
* Follow some consistent naming patterns for functions/methods:
* Follow some consistent naming patterns for functions/methods:
** A method which return an object pointer and expects the calling code to delete the object after use, should be named makeFOO; so for example, FSNode::openForReading() would become FSNode::makeReadStream()
** A method which return an object pointer and expects the calling code to delete the object after use, should be named makeFOO; so for example, FSNode::openForReading() would become FSNode::makeReadStream()
Line 65: Line 81:
};
};
</syntax>
</syntax>
* merge EventManager::shouldQuit and shouldRTL: many places need to check *both* anyway, but this is often "forgotten" (and this problem then quickly proliferates, because people use copy&paste but don't read the docs). it would be more intuitive if they were combined into one:
<syntax type="C++"> 
  QuitRequest shouldQuit()
 
  enum QuitRequest {
  kNoQuitRequest = 0,
  kRTLRequest = 1,
  kQuitRequest = 2
  }
</syntax>
This would also reduce the calling overhead slightly, as now only one virtual method has to be called now instead of two).




Line 79: Line 106:
** improved GUI experience for small devices *and* "big" devices ?
** improved GUI experience for small devices *and* "big" devices ?
** helpful for localization
** helpful for localization
* Localize ScummVM
** initially only to systems with 8bit encodings
** investigate "full" UTF-8 encoding support. May be too muchfor small ports, though. Can we switch between both approaches during compile time?
** use gettext for localization?
** investigate existing localization patch(es)
** translate engines as well? what about errors?


* add support for saving/loading from the GMM in more engines
* add support for saving/loading from the GMM in more engines
Line 113: Line 133:
** for the others, what needs to be done to fix this?
** for the others, what needs to be done to fix this?
** what about engine support? i.e. letting engines specify which "keys" a given game wants?
** what about engine support? i.e. letting engines specify which "keys" a given game wants?
* why do some ARM targets not use all ARM assembler code?
** maybe enable it all for ARM builds, and let ARM ports explicitly *disable* it if necessary?
* merge NDS changes from branch into trunk


== Wish list ==
== Wish list ==
1,079

edits