Difference between revisions of "Compiling ScummVM/Visual Studio"

From ScummVM :: Wiki
Jump to navigation Jump to search
(Updated the library links)
(Added FLAC libraries)
Line 43: Line 43:
 
* [ftp://ftp.mars.org/pub/mpeg/ libmad] for MP3 support.  
 
* [ftp://ftp.mars.org/pub/mpeg/ libmad] for MP3 support.  
 
Latest stable version at the time of writing this: [ftp://ftp.mars.org/pub/mpeg/libmad-0.15.1b.tar.gz 0.15.1b]
 
Latest stable version at the time of writing this: [ftp://ftp.mars.org/pub/mpeg/libmad-0.15.1b.tar.gz 0.15.1b]
 +
 +
* [http://sourceforge.net/project/showfiles.php?group_id=13478&package_id=12677 libFLAC] for FLAC support.
 +
Latest stable version at the time of writing this: [http://sourceforge.net/project/showfiles.php?group_id=13478&package_id=12677&release_id=539981 1.2.1]
  
 
* [http://libmpeg2.sourceforge.net/downloads.html libmpeg2] for MPEG-2 support.  
 
* [http://libmpeg2.sourceforge.net/downloads.html libmpeg2] for MPEG-2 support.  

Revision as of 23:28, 15 May 2009

Compiling ScummVM with Visual Studio 2003/2005 under Windows

Compiling ScummVM under Windows is not an awfully hard task, however there are some things that don't just work out of the box


Things needed

Visual Studio 2008

There exist several versions of Visual Studio 2008. A feature comparison can be found here

You can obtain the free Express version of VS2008 here

Although Visual Studio 2008 is preferred if you happen to use the older Visual Studio 2005 you have to have at least Service Pack 1 installed for it (as Visual Studio 2005 without Service Pack 1 has problems with ScummVM's template code).

Precompiled libraries

To ease the whole process, a package of all the needed precompiled libraries has been created. All you need to do is:

  • Download the precompiled libraries and the latest SDL runtime library - latest version is 1.2.12 at the time this was written, you can find the latest version here. Mirrors for precompiled libraries:
  • Unzip the precompiled libraries archive maintaining directory structure
  • Run install.bat (Visual Studio 2005/2008 only)
  • You don't need to add the libraries to Visual Studio, as the installer automatically copies the necessary files in the appropriate directories of Visual Studio. Please note that this installer has only been tested with Visual Studio 2005 and 2008. If you get errors with earlier versions of Visual Studio, simply copy the directories bin, lib and include inside the directory where Visual C++ is installed. If you're not sure how to do that, check the section "Adding all libraries to Visual Studio" further on
  • Unzip sdl.dll from the SDL runtime in the same directory where the scummvm executable will be created (default is under dits\msvc9\scummvm_Release, substitute msvc9 for msvc8 if you're using Visual Studio 2005 and msvc7 if you're using Visual Studio 2003)
  • Skip to step "Ready to compile ScummVM"

Libraries needed

  • SDL 1.2, file SDL-devel-1.2.XX-VC8.zip (where XX is the current release number)

Latest stable version at the time of writing this: 1.2.13

Latest stable version at the time of writing this: 2.06rc12

Note that the libraries included in the "vorbis" package won't work. You need libogg and libvorbis, not vorbis. Latest stable versions at the time of writing this: 1.1.3 and 1.2.0.

Latest stable version at the time of writing this: 0.15.1b

Latest stable version at the time of writing this: 1.2.1

Get the latest mpeg2dec release from this page, libmpeg2 is included there. Latest stable version at the time of writing this: 0.5.1

You need the latest zlib source code. If you wish to compile ScummVM 0.8.0 or earlier with zlib support, you'll also need crtdll.lib. Latest stable version at the time of writing this: 1.2.3


Building the libraries

Now, we need to compile the required libraries.

Note that you'll need to build all libraries with the same configuration settings (debug or release). If you don't need a specific library, you can remove it from your build by going to Project->Properties, Configuration Properties->C/C++->Preprocessor and remove the "USE_XXX" directive for that library from there. For example, to remove OGG support, remove the USE_VORBIS directive


A note about VS2008/2005

If you're building the libraries with VS2008/2005, you will get a lot of deprecation warnings. These are normal and nothing to worry about, they're just Microsoft's way of saying "This is a bad code practice. Use this instead". It's not easy to turn these off without several modifications to the code, so just ignore them.

Read more here:

http://msdn.microsoft.com/msdnmag/issues/05/05/SafeCandC/

http://www.gamedev.net/community/forums/topic.asp?topic_id=361433

http://blogs.msdn.com/oldnewthing/archive/2005/01/07/348437.aspx

If you do wish to make them disappear, you need to include on top the main function of each library, before the includes, the following lines:

 #if (_MSC_VER >= 1400) /* VC8+ (VS2005) */
 #pragma warning(disable : 4996) /* Disable all deprecation warnings */ 
 #endif /* VC8+ (VS2005) */


NASM

First of all, we need nasm. So unzip the nasm archive in a directory, copy "nasmw.exe" to "nasm.exe" (because some projects call one and others call the other) and include it in the executable path of VS. To do this, go to Tools->Options->Projects and solutions->VC++ directories. Select "Executable files" from the top right and include the directory where you unzipped nasm into.


SDL

SDL is already compiled and needs no further changes, so we can skip the compilation step for it


zlib

You'll need the zlib source package. Go into the projects directory in the zlib source and open the solution there. For each of the 3 projects in the solution (example, minigzip and zlib) you need to right-click it in the solution explorer and go to properties. Then, go to Configuration Properties->C/C++->Code Generation and change the Runtime library from "Multi-Threaded DLL (/MD)" to "Multi-Threaded (/MT)". When you've changed all three projects, compile the solution using the LIB release configuration.


libogg

Compile this first, as many other libraries need it. Go to the win32 directory and build the ogg solution in there. DON'T compile the solution in the VS2003 directory, as this produces "libogg.lib" instead of "ogg.lib". A simple rename might work, though


libvorbis

Before compiling this, include the libogg include and library paths in VS. To do this, go to Tools->Options->Projects and solutions->VC++ directories and include the include directory of libogg as well as the directory with the compiled ogg library


mpeg2dec

Open the solution and compile project "libmpeg2". After you compile it, go to its include directory, create a folder "mpeg2dec" in there and copy all files from the include folder in this subfolder. You will end up with 2 directories, "include" and "include\mpeg2dec" with the same files. This is needed, as ScummVM includes files from the "mpeg2dec" directory


libmad

Open and compile the "libmad" solution


FLAC

Open its solution and compile the libFLAC_static project.


Adding all libraries to Visual Studio

There are two ways of adding the libraries to Visual Studio. You can either copy all the header and library files inside the appropriate directories of Visual C++ or tell Visual C++ where to look for them.

First method: Copy the files inside VC++'s folders

The first method of adding the required libraries is to go to each individual compiled library and copy the header and library files.

You'll need the following:

Libraries

 libFLAC_static.lib - static build of libFLAC (from folder obj\release\lib where you unzipped libFLAC)
 libmad.lib - static build of libMAD (from folder msvc++\Release where you unzipped libmad)
 libmpeg2.lib - static build of libMPEG2 (from folder vc++\Release where you unzipped mpeg2dec)
 ogg_static.lib - static build of libOGG (from folder win32\Static_Release where you unzipped libogg)
 sdl.lib - static build of SDL (from folder lib where you unzipped SDL)
 vorbisfile_static.lib - static build of vorbisfile (from folder win32\VorbisFile_Static_Release where you unzipped libvorbis)
 vorbis_static.lib - static build of libvorbis (from folder win32\Vorbis_Static_Release where you unzipped libvorbis)
 zlib.lib - static build of zlib (from folder projects\visualc6\Win32_LIB_Release where you unzipped zlib)

Copy those inside VC's lib folder (e.g. C:\Program Files\Microsoft Visual Studio 8\VC\lib)

Header files

 [TODO]

Copy those inside VC's include folder (e.g. C:\Program Files\Microsoft Visual Studio 8\VC\include)

Executable files

 nasmw.exe - from the NASM zip

Copy this as nasmw.exe AND as nasm.exe inside VC's bin folder (e.g. C:\Program Files\Microsoft Visual Studio 8\VC\bin)

Second method: Tell VC++ where to look

The second method is to tell VC++ where to look for the required libraries and header files

Go to Tools->Options->Projects and solutions->VC++ directories.

In the executable files section, make sure that the path to nasm is included and that nasmw.exe in that folder has been copied to nasm.exe. Failure to do that will give you an error in VS (a custom building step has returned an error)

In the include files section, make sure that the include folders for libogg, libvorbis, libmad, zlib, mpeg2dec and SDL are in the list. If you need FLAC, include the FLAC include folder in the list too

In the library files section, make sure that the static libraries for vorbis, vorbisfile, libogg, zlib, mpeg2dec, libmad and SDL are included. If you're building 0.8.0 final or earlier, include the release folder of zlibdll too (in the zlib source folder, contrib\vstudio\vc8\x86\zlibdllrelease). If you need FLAC, include the FLAC libraries folder too

Finally, if you need to compile ScummVM with FLAC support, go to Configuration Properties->C/C++->Preprocessor and add "USE_FLAC" in the Preprocessor Definitions field. Also, go to linker->input and add "libflac_static.lib" in the Additional Dependencies field.


Enabling the console

Since information on doing this is not that easy to find, here's how to enable the console in the resulting ScummVM executable. The default project subsystem is "Windows" instead of "Console", which means that the console will not be shown.

To show the console, right-click on the "scummvm" project and go to Properties. There, go to Configuration Properties->Linker->System and change the "Subsystem" property from "Windows (/SUBSYSTEM:WINDOWS)" to "Console (/SUBSYSTEM:CONSOLE)". Then, go to Linker->Advanced and set the entry point to be "WinMainCRTStartup" (special thanks to Jubanka/knakos for his tip on entrypoint).


Ready to compile ScummVM

If you got all the libraries compiled, you're ready to compile the latest version of ScummVM!

Open the solution file in dists\msvc9 (msvc8 for VS2005 and msvc7 for VS2003), select the "Release" configuration from the configuration manager pulldown menu and then go to Build->Build solution, or just press Control-F7 to compile it.

The ScummVM executable should be in the folder dists\msvc9\scummvm_Release as "scummvm.exe".

You'll need to copy sdl.dll from the SDL runtime archive (or the latest devel archive) in the directory where scummvm.exe is