1,079
edits
(→Misc) |
(Updated my personal TODO list) |
||
Line 22: | Line 22: | ||
* Show "Release Date" on download page | * Show "Release Date" on download page | ||
* Use AJAX for screenshot display? | * Use AJAX for screenshot display? | ||
* Use AJAX to improve the downloads page, by only showing the most important ports/downloads by default, and then uncovering the rest upon a click by the user (with gracious fallback if Javascript is disabled). | |||
=== Savefile manager === | === Savefile manager === | ||
* Consider replacing "const char *" | * Consider replacing "const char *" with "Common::String" in method parameters. This might or might not be a good idea, though -- don't just do it blindly! | ||
=== GUI === | === GUI === | ||
* The options dialog may show a button for configuring the savepath even on systems where it is fixed -> not good. This button should be hidden/removed for these systems | * The options dialog may show a button for configuring the savepath even on systems where it is fixed -> not good. This button should be hidden/removed for these systems | ||
* Highlight the "default" button in dialogs (e.g. the classic MacOS way, drawing a fat border around it; or by using different coloring; or a combination). This falls under "usability", too. | * Highlight the "default" button in dialogs (e.g. the classic MacOS way, drawing a fat border around it; or by using different coloring; or a combination). This falls under "usability", too. | ||
* Global Main Menu | |||
** Allow engines to extend this more freely. E.g. for the SCUMM engine, we would want to add a "Help" button | |||
** Make it possible to reach the "key remapper" and "virtual keyboard" from the GMM, if available? | |||
** Sugar on the cake: In addition to the ScummVM logo and version, how about showing the engine name and game title at the top of the GMM? | |||
=== OSystem === | === OSystem === | ||
* get to rid of the evil global gBitFormat! | * get to rid of the evil global gBitFormat! | ||
* Remove slack in OSystem | * Remove slack in OSystem | ||
** move getScreenChangeID functionality to EventManager | ** move getScreenChangeID functionality to EventManager | ||
* Implement the [https://sourceforge.net/mailarchive/forum.php?thread_name=41C50AFD-4544-4465-BD00-C058F04BC386%40quendi.de&forum_name=scummvm-devel RFC: Flexible keymapping via new EVENT_ (post 0.10)] | * Implement the [https://sourceforge.net/mailarchive/forum.php?thread_name=41C50AFD-4544-4465-BD00-C058F04BC386%40quendi.de&forum_name=scummvm-devel RFC: Flexible keymapping via new EVENT_ (post 0.10)] | ||
* Change backends to use namespaces ?! (Not really that useful, I guess, except for the Doxygen pages) | * Change backends to use namespaces ?! (Not really that useful, I guess, except for the Doxygen pages) | ||
Line 72: | Line 60: | ||
=== Misc === | === Misc === | ||
* It might be quite helpful if we followed some consistent naming patterns for functions/methods. For example, a method which return an object pointer and expects the calling code to delete the object after use, should be named makeFOO; so for example, FSNode::openForReading() would become FSNode::makeReadStream() | |||
* Remove the 'addDefaultDirectory' calls from runGame in base/main.cpp. Reason: Their presence causes an asymmetry between the "detect a game" and "run a game" use cases, as different files are "seen" in each case. This can lead to subtle bugs, and also causes ugly code duplication in the AdvancedDetector code right now (there to work around asymmetries like this one) | * Remove the 'addDefaultDirectory' calls from runGame in base/main.cpp. Reason: Their presence causes an asymmetry between the "detect a game" and "run a game" use cases, as different files are "seen" in each case. This can lead to subtle bugs, and also causes ugly code duplication in the AdvancedDetector code right now (there to work around asymmetries like this one) | ||
* add plugin API to fetch a fresh desc string for a given target ?!? | * add plugin API to fetch a fresh desc string for a given target ?!? |
edits