Changes

Jump to navigation Jump to search

Compiling ScummVM/Visual Studio

4,858 bytes removed, 20 April
no edit summary
== Compiling ScummVM with Visual Studio 2008/2010 under Windows ==
 Compiling ScummVM under Windows with Visual Studio is not an awfully hard task, . It is however there are some things that don't just work out of slightly more complicated than using MinGW. We guide you through the boxsteps to make ScummVM compile with Visual Studio on this page.
== Things needed ==
Visual Studio 2008-2019
=== Visual Studio 2010 or 2008 ===There exist several versions of Visual Studio 2010. A feature comparison can be found [http://msdn.microsoft.com/vstudio/products/compare/default.aspx here] You can obtain the exists a free Express Community version of Visual C++ 2010 Studio [httphttps://msdnvisualstudio.microsoft.com/vstudio/express/default.aspx here] Although Visual Studio 2010 or 2008 is preferred, older versions of Visual Studio may work so long as you have them updated to their latest Service Pack revisions. In fact, we suggest making sure that you always have the latest Service Packs and patches applied for these tool sets. In some cases, fixes were put into the free-to-download "Processor Pack" add-on for Visual C++. So, download the latest Service Pack and the latest Processor Pack for whatever version of Visual C++ you are using to make sure you won't run into compiler bugs that prevent the compilation of scummvm. === Precompiled libraries ===To ease the whole process, a package of all the needed precompiled libraries has been created. All you need to do is:* Download the precompiled libraries and the [http://www.libsdl.org/release/SDL-1.2.12-win32.zip latest SDL runtime library] - latest version is 1.2.12 at the time this was written, you can find the latest version [http://www.libsdl.org/download-1.2.php here]. Mirrors for precompiled libraries:** [http://robertmegone.com/scummvm/build/scummvm_vs_libs.zip Mirror 1]** [http://rapidshare.com/files/444276747/scummvm_vs_libs.zip Mirror 2] (RapidShare)** [http://hotfile.com/dl/99156254/041529e/scummvm_vs_libs.zip.html Mirror 3] (Hotfile)* Unzip the precompiled libraries archive maintaining directory structure* Run install.bat (Visual Studio 2005/2008 only)* You don't need to add the libraries to Visual Studio, as the installer automatically copies the necessary files in the appropriate directories of Visual Studio. Please note that this installer has only been tested with Visual Studio 2005 and 2008. If you get errors with earlier versions of Visual Studio, simply copy the directories ''bin'', ''lib'' and ''include'' inside the directory where Visual C++ is installed. If you're not sure how to do that, check the section "[[Compiling_ScummVM/Visual_Studio#Adding_all_libraries_to_Visual_Studio|Adding all libraries to Visual Studio]]" further on* Unzip sdl.dll from the SDL runtime in the same directory where the scummvm executable will be created (default is under dits\msvc9\scummvm_Release, substitute msvc9 for msvc8 if you're using Visual Studio 2005 and msvc7 if you're using Visual Studio 2003)* Skip to step "[[Compiling_ScummVM/Visual_Studio#Ready to compile ScummVM|Ready to compile ScummVM]]" === Building the libraries yourself ===Refer to the [[Compiling_ScummVM/Visual_Studio/Compiling_Libraries|instructions for compiling the libraries yourself]]  == Adding all libraries to Visual Studio 2010== The way libraries are added has been changed in Visual Studio 2010, compared to earlier versions. Copy all of the precompiled libraries in a separate folder (e.g. c:\scummvm_libs). Then, there are two different ways of adding this directory to Visual Studio:* Right click My Computer->Properties->Advanced (Win 2000/XP) or Advanced System Settings->Advanced (Vista/Win 7)->Environment Variables->New (System Variable), with a variable name of "SCUMMVM_LIBS" and a value of the folder where you unpacked your precompiled libraries (eused.g. "C:\scummvm_vs_libs")* If the above method doesn't work, open the ScummVM solution in Professional Visual Studio, and go to View->Property Manager or View->Other Views->Property Manager (depending on your layout configuration). From there, open the scummvm project, and go to the configuration you want to build (e.g. Debug|Win32) and click on "Microsoft.Cpp.Win32.user". From there, go to "VC++ directories" and add the 3 library directories in the appropriate places, i.e.:  Executable Directories: add "C:\scummvm_vs_libs\bin;" at the beginning Include Directories: add "C:\scummvm_vs_libs\include;" at the beginning Library Directories: add "C:\scummvm_vs_libs\lib\x86" (or x64, if you're building a 64-bit version) at the beginning If if still fails to build, saying it can't find a lib file, go to the project properties of the scummvm project, Configuration Properties->Linker->General->Additional Library Directories and add your lib folder in there  == Adding all libraries to Visual Studio 2005/2008 == There Studioversions are two ways of adding the libraries to Visual Studio. You can either copy all the header and library files inside the appropriate directories of Visual C++ or tell Visual C++ where to look for them.<br><br> === First method: Copy the files inside VC++'s folders ===The '''first method''' of adding the required libraries is to go to each individual compiled library and copy the header and library files.  You'll need the following:<br><br>'''Libraries'''<br> '''libFLAC_static.lib''' - static build of libFLAC (from folder obj\release\lib where you unzipped libFLAC) '''libmad.lib''' - static build of libMAD (from folder msvc++\Release where you unzipped libmad) '''libmpeg2.lib''' - static build of libMPEG2 (from folder vc++\Release where you unzipped mpeg2dec) '''libpng.lib''' - static build of libpng (from folder projects\visualc71\Win32_LIB_Release where you unzipped libpng) '''ogg_static.lib''' - static build of libOGG (from folder win32\Static_Release where you unzipped libogg) '''sdl.lib''' - static build of SDL (from folder lib where you unzipped SDL) '''vorbisfile_static.lib''' - static build of vorbisfile (from folder win32\VorbisFile_Static_Release where you unzipped libvorbis) '''vorbis_static.lib''' - static build of libvorbis (from folder win32\Vorbis_Static_Release where you unzipped libvorbis) '''vorbisenc_static.lib''' - static build of libvorbis (from folder win32\Vorbisenc_Static_Release where you unzipped libvorbis) '''zlib.lib''' - static build of zlib (from folder projects\visualc6\Win32_LIB_Release where you unzipped zlib) Copy those inside VC's lib folder (e.g. C:\Program Files\Microsoft Visual Studio 8\VC\lib)<br><br>'''Header files'''<br> [TODO] Copy those inside VC's include folder (e.g. C:\Program Files\Microsoft Visual Studio 8\VC\include)<br><br>'''Executable files'''<br> '''nasmwworking fine too.exe''' - from the NASM zip
Copy We do support older versions of Visual Studio too. However, on this as nasmw.exe AND as nasmpage we focus on building ScummVM with Visual Studio.exe inside VC's bin folder (e.g. C:\Program Files\Microsoft Building ScummVM with older Visual Studio 8\VC\bin)<br><br>2008 can require additional work not described on this page.
=== Second method: Tell VC++ where to look Needed Libraries ===The '''second method''' is ScummVM relies on third-party libraries to tell VC++ where to look implement certain functionality. Some of these libraries are required, like for example SDL, others are optional, like for example libtheora. We supply a set of prebuilt libraries for Visual Studio 2015. These have been build on Windows 8.1 using the required Visual Studio 2015 Community Edition. The libraries and header filescan be found [http://www.scummvm.org/frs/build/scummvm_libs_2015.zip here].
=== Installing Libraries ===The easiest way to make Visual Studio find the supplied libraries is by using the environment variable "SCUMMVM_LIBS". We describe this method now.To make it work you have to follow these steps:* Unzip the library zip to a directory of your choice. For example, you can unzip them into "C:\Users\YourUsername\Documents\scummvm_libs_2015".* Go to ToolsControl Panel ->Options->Projects Environment Variables and set up a new variable "SCUMMVM_LIBS" with a value of the path you extracted the zip in. It is important that you do point the variable to the folder containing the "bin", "include", and solutions->VC++ "lib" directories.
In === Manually Building Libraries ===If you want to build libraries for use with Visual Studio yourself, please refer to the executable files section, make sure that [[Compiling_ScummVM/Visual_Studio/Compiling_Libraries|instructions for compiling the path to nasm is included and that nasmwlibraries yourself]].exe in that folder has been copied to nasm.exe. Failure to do that will give you an error in VS (a custom building step has returned an error)
In == Preparing the include files section, make sure that the include folders for libogg, libvorbis, libmad, zlib, mpeg2dec and SDL are in the list. If you need FLAC, include the FLAC include folder in the list too Project Files ==
In the library files section, make sure that the static libraries for vorbis, vorbisfile, libogg, zlib, mpeg2dec, libmad and SDL are included. If you're building 0.8.0 final or earlier, include the release folder of zlibdll too (in the zlib source folder, contrib\vstudio\vc8\x86\zlibdllrelease). If you need FLAC, include the FLAC libraries folder too === Building create_project ===
Finally, if you need to compile ScummVM with FLAC support, go uses a configure/Make based build system. We have a tool to Configuration Properties->C/C++->Preprocessor and add "USE_FLAC" in the Preprocessor Definitions fieldgenerate Visual Studio project files from this build system. Also, go The first steep you need to linker->input and add take is building this tool called "libflac_static.libcreate_project" in the Additional Dependencies field.
First, open the solution file "devtools\create_project\msvc\create_project.sln". Then simply build the solution. The project file should automatically assure that the resulting "create_project.exe" is copied to "dists\msvc". If not, you will have to copy it yourself.
== Enabling = Generating the console Project Files ===
Since information on doing this is not that easy to find, here's how to enable Simply run the console in the resulting ScummVM executablebatch script "dists/msvc/create_msvc.The default project subsystem is bat"Windows" instead of "Console", which means that the console . It will not be shownguide you through configuring ScummVM.
To show the console, right'''IMPORTANT''': You will have to re-click on generate the "scummvm" project and go files whenever new source files have been added to Properties. There, go to Configuration Properties->Linker->System and change or removed from the "Subsystem" property from "Windows (configure/SUBSYSTEM:WINDOWS)" Make based build system. When you add new files to "''ScummVM, you will 'Console (/SUBSYSTEM:CONSOLE)'have''". Then, go to Linker->Advanced and set add them to the entry point to be respective "'''WinMainCRTStartup'''module.mk" (special thanks file to [[User:Jubanka|Jubankaassure ScummVM still builds fine with the configure/knakos]] for his tip on entrypoint)Make based build system.
== Compiling ScummVM ==
== Ready If you followed all the steps, you are now ready to compile ScummVM ==with Visual Studio. Congratulations!
If you got all Simply open the libraries compiled, generated solution file in "dists\msvc\scummvm.sln". Now you're ready can ask it to compile build the latest version of desired configuration. By default it will build a debug configuration which is ideal to hack on ScummVM!.
Open '''IMPORTANT''': You'll need to copy the matching SDL.dll file to a location Windows picks up to run the solution resulting binary. The easiest way to do this is to place the SDL.dll file in dists\msvcXX (msvc10 for VS2010the directory where scummvm.exe is. There are multiple SDL.dll files to choose from, msvc9 for VS2008 or msvc8 for VS2005), select depending on your build configuration. Simply pick the "Release" configuration right one from the prebuilt libraries. For example, if you build a Win32 Debug configuration manager pulldown menu and then go to Build->Build solution, or just press Control-F7 you will need to compile ituse "libs/x86/Debug/SDL.dll".
The ScummVM executable should be in the folder dists\msvc9\scummvm_Release as "scummvm.exe".== Compiling without Console/Status Window ==
You'll If you want to run ScummVM without the console Window being present by default, there are two things you need to copy do:* In the Project Options for the scummvm project, go to the Linker | System | SubSystem line, and change the /SUBSYSTEM:CONSOLE to /SUBSYSTEM:WINDOWS* In the file backends/platform/sdl/win32/win32.dll cpp, change the parameter from true to false in the SDL runtime archive first line of OSystem_Win32::initBackend: ConfMan.registerDefault(or the latest devel archive"console", false) in the directory where scummvm.exe is;

Navigation menu